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Preparation of publication-quality videos using ImageJ 

Statements made in scientific papers are often much easier to understand if they are 

supplemented by representative videos. In the best case, these videos demonstrate the 

real-time observations made by the paper’s authors that led to the quantification presented 

in an article. This is especially true in research relying on time-lapse microscopy techniques.  

A number of tools exist to prepare publication-quality videos from raw movies. I prefer to 

use ImageJ, which is a free, open-source image analysis platform from the U.S. National 

Institutes of Health (NIH, Bethesda, MD - http://imagej.nih.gov/ij/).  

Here, I will go through the steps I use to prepare videos using ImageJ. My objective is to 

combine two separate movies so that they can be played simultaneously and side-by-side to 

facilitate comparison. Both movies were both captured at 10x magnification on a Nikon 

Eclipse Ti microscope in the Konstantopoulos Lab at Johns Hopkins University and are 

courtesy of the lab. One movie shows MDA-MB-231 breast cancer cells migrating inside an 

engineered microchannel that is slightly wider than the cell body. The other shows cells 

from the same cell line migrating on a two-dimensional (2D) surface. Cells polarize and 

migrate persistently, with a single leading edge, inside the microchannels, whereas 

migration is random in 2D. By viewing the movies side-by-side, this is clearly evident.  

Note on video files 

ImageJ can handle most video file types, as well as open propriety file types (for example, 

.nd2 files from Nikon) and save them to more widely-accessible formats (.avi, .mov, etc.) 

accepted as supplementary files in journal publications. However, plugins may be required 

to open some file types. 

Step 1: Open videos in ImageJ 

Open your video files in ImageJ. This may require downloading an ImageJ plugin. Plugins 

are easily found with a web search. The Bio-Formats plugin 

(http://loci.wisc.edu/software/bio-formats) is especially useful for opening proprietary file 

types used by microscope manufacturers. Once files are open, it is often helpful to save 

them as .tif or .avi files for future use (File→Save As→Tiff or AVI). 

Here, I have opened two videos (Figure 1). The left-hand video shows cell migration inside a 

microchannel. The right-hand video shows cells migrating on a 2D surface. These videos 

were already saved in the .avi file format. A video is referred to a “stack” in ImageJ, with a 

series of images organized one after the other. All stacks have the “play” button and slide 

bar visible at the bottom of the image stack. 

http://imagej.nih.gov/ij/
http://loci.wisc.edu/software/bio-formats
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Figure 1: Two separate movie files open in ImageJ (referred to hereafter as stacks). The left-hand stack shows an 

engineered microchannel (20 µm wide, 10 µm tall) with an MDA-MB-231 cell at the microchannel entrance. The 

right-hand stack shows MDA-MB-231 cells on a flat, 2D surface.  

 

Step 2: Rotate and crop stacks as necessary 

In ImageJ, stacks can be rotated and cropped. For example, the left-hand stack could be 

rotated so that the long axis of the microchannel is oriented in another direction. This can 

correct for off-axis orientation in the raw files if the specimen was not placed in exact 

alignment on the microscope state. 

To rotate an image, select Image→Transform→Rotate (Figure 2). This brings up the Rotate 

interface (Figure 2). 

      

Figure 2: Commands to rotate an image, and the Rotate user interface that pops up. 
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By selecting “Preview” and changing the rotation angle, you can see how to adjust the 

image to achieve your desired image orientation. In Figure 3, I have chosen to show 32 grid 

lines to assist in alignment. Rotation is usually an iterative process, with the rotation angle 

adjusted incrementally by the user until the desired orientation is found. 

 

Figure 3: Example of image rotation in ImageJ. The active window on the left is being rotated 15 degrees. Note 

that the “Preview” box is checked so that I can see what affect a given rotation angle will have on my image. 

My stacks were already oriented correctly, so I will not rotate them here. 

Furthermore, stacks can be cropped to show the desired region of interest. I generally crop 

stacks after rotating so that I can remove some of the black border created upon rotation. 

The first step in cropping an image is selecting the region you want to crop. I do this using 

the rectangular selection tool (Figure 4, red arrow).  

 

Figure 4: The red arrow points to the rectangular selection tool, which has been selected.  



©Colin Paul  Updated 14 November 2014 

4 

 

After choosing the selection tool, outline the region you want to remain after cropping with 

the shape tool (what is inside the yellow box in Figure 5 will remain after cropping). 

 

Figure 5: Image with region of interest to be cropped (yellow rectangle). The region inside the yellow rectangle 

will remain after executing the crop command. 

I find it useful to crop both movies to the same size so that they can be readily assembled 

side-by-side. The easiest way to do this is to use the ROI (stands for “region of interest”) 

manager in ImageJ. With the ROI manager, you can save the selected region in one image 

and propagate it to another open image so that the images resulting from cropping will be 

identical in size. To send a selection to the ROI mananger, press “t” after drawing the 

selection on the initial image. This will open the ROI manager, and your ROI will be listed 

(Figure 6). 

 

Figure 6: The rectangular ROI created above has been sent to the ROI manager by pressing “t”. 

This is the ROI for the 

rectangular box shown on 

the left-hand image of the 

Figure. 
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Now, the ROI can be propagated to the second image. Click the second image to make it 

the active window, and then click the name of the ROI in the ROI manager. The selection 

will appear on the second image (Figure 7). 

 

Figure 7: The ROI defined in the left-hand image has been propagated to the right-hand image by selecting the 

second image and clicking on the name of the ROI in the ROI manager. 

The images can then be cropped to generate two movies of identical pixel dimensions. To 

crop, select one of the images, and then choose Image→Crop (Figure 8). Repeat for other 

open images. 

 

Figure 8: Command to crop an image to the size of an ROI. 

After cropping, both images should have the same dimensions. You can check whether this 

is the case by looking at the x- and y-lengths of the images, which are displayed under the 
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stack name (red arrows in Figure 9). Both of the example images have been cropped to 

264x397 pixels. 

 

Figure 9: Cropped images. Note that the images are identical in size (264x397 pixels). The size of each image is 

given below the name of the stack (red arrows). 

 

Step 3: Trim videos to show desired time range 

Movies have a defined number of frames, or still images. When preparing a video for 

publication, it can be helpful to trim the video to minimize file size and avoid showing 

periods during which nothing of consequence happens. However, videos should not be 

trimmed to arbitrarily change the outcome of an experiment.  

For the creation of a single video showing multiple experiments side-by-side, it is necessary 

to trim the raw movie files to the same length so that they can be combined to a single file 

with a defined number of frames. Both stacks below are 27 frames long (Figure 10, red 

arrows), so they do not need to be trimmed further.  
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Figure 10: Both stacks shown here are 27 frames long. The frame characteristics (given as active frame/frames 

total; these show frame 1 of 27) are shown under the name of the stack (red arrows). 

Stacks can be trimmed using the Substack Maker tool. This tool is accessed by selecting 

Image→Stacks→Tools→MakeSubstack… (Figure 11). Once the Substack Maker user interface 

is brought up, the desired frames for retention can be typed in. For example, if one of my 

stacks was 40 frames long, and I wanted to make it 27 frames long while showing the last 

27 frames in my final video, I would type in “14-40” next to “Slices:” in the Substack Maker. 

  

Figure 11: Commands to open Substack Maker. The Substack Maker is used to trim frames from a stack. 
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Step 4: Set image properties 

When images are opened in ImageJ, they may or may not contain metadata about the 

original image capture, depending on the original file type and the manner in which it was 

opened. Images with metadata typically contain the correct pixel-to-micron conversion that 

is required to add a scale bar to an image. However, if metadata has not been retained, the 

image properties can be entered manually. In the stacks shown here, the image size is 

presented in pixels. These images were taken on an optical system in which the conversion 

of pixels to microns was 0.647 µm/pixel, with subsequent images in the stacks taken 10 

minutes apart.  

To set image properties, click on Image→Properties (Figure 12). 

 

Figure 12: Commands to set image properties. 

Opening the image properties interface allows you to enter the unit of length, pixel height, 

pixel width, and frame interval (Figure 13). For creation of videos, voxel depth is not 

important. Once image properties have been set, it is convenient to check the “Global” box 

to propagate these properties to other images. This avoids having to set properties for each 

stack individually. 
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Figure 13: Image property interface; here, the open stacks are being set for a magnification calibration of 0.647 

µm/min, with 10 minutes between subsequent images in the stacks. 

 

Step 5: Combine stacks 

Stacks that are the same height and length (number of frames) can be combined 

horizontally into a single stack. Similarly, stacks of the same width and number of frames 

can be combined vertically into a single stack. Combination of multiple stacks generates a 

single stack that can be saved and played as a single video file. 

To combine stacks, select Image→Stacks→Tools→Combine…(Figure 14). These commands 

bring up the Combiner user interface (Figure 15). This interface allows the user to select the 

stacks to combine. The default setting is to combine the stacks horizontally, or side-by-side. 

The file chosen as “Stack 1” will be placed on the left of the resulting combined stack, and 

the file chosen as “Stack 2” will be placed on the right. If images are best combined 

vertically, the “Combine vertically” box can be selected. 
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Figure 14: Commands to combine multiple stacks. 

 

Figure 15: Combiner user interface. To combine the stacks horizontally (side-by-side), do not check the “Combine 

vertically” box. 

Execution of the Combiner command generates a single stack. This stack can be saved as a 

single video file in which the constituent stacks will play simultaneously (Figure 16). 
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Figure 16: Combined stacks generated using the Combiner tool. The two constituent stacks have been combined 

to a single stack, and both videos play if the play button is selected. 

 

Step 6: Create a border for the video 

I prefer to put a border around my videos to clean up the look of the final video and provide 

space for labels and time stamps. Making a border is especially useful if you have rotated an 

image and want to hide the black filled-in area created by rotation.  

The first step in creating a border is choosing a border color. Double click on the Color 

Picker tool (Figure 17, red arrow) to bring up the color palette (CP, Figure 17). Click on the 

desired border color in the palette. I chose to create a red border. 

 

Figure 17: Double-click the Color Picker (red arrow) to bring up the color palette (CP) and choose a color for the 

border. 
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Create a ROI to be filled in by the selected color. In Figure 18, a rectangular ROI has been 

drawn on the stack using the rectangular ROI tool. 

 

Figure 18: A rectangular ROI drawn on the stack will be filled in with the border color. 

To fill in the ROI, select Edit→Fill (Figure 19). A prompt asking if the ROI should be filled in 

all images will come up; choose “Yes”. 

 

Figure 19: Commands to fill an ROI with the color chosen with the Color Picker tool. 

Now that the ROI has been filled (Figure 20), make the coloring permanent by drawing it on 

the image. Select Edit→Draw (Figure 20). Another prompt asking if the ROI should be drawn 

in all images will come up; choose “Yes”. 
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Figure 20: Commands to draw a filled ROI on a stack. 

Repeat these steps to create a border around the image and, if desired, between the 

original stacks (Figure 21). 

 

Figure 21: Stack after drawing red borders on all sides. 
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Step 7: Add a scale bar to the stack 

All published images and videos should include a scale bar to give the reader an idea of the 

size of the objects in the image. Scale bars are dependent on the image properties (see 

Step 4). To add a scale bar to an image, select Analyze→Tools→Scale Bar… (Figure 22). 

 

Figure 22: Commands to add a scale bar to an image. 

Executing the commands to add a scale bar brings up the ScaleBar Plus interface (Figure 

23). Type in the desired width of the scale bar, and adjust the scale bar height and font size 

as appropriate for the image. Make sure the “Label all slices” box is selected so that the 

scale bar will show up on every frame of the stack. 

There are several options for placing the scale bar on the stack. The “Location” drop-down 

menu allows the user to choose whether to place the scale bar at the lower right, lower left, 

upper right, or upper left of the image, or at a specified point in the image. If the scale bar 

is being placed at specified point, draw an ROI on the image (easiest to do using the 

rectangular ROI tool) prior to executing the commands to create a scale bar. Then, choose 

“At selection” for the scale bar location. The ROI I drew to place the scale bar (yellow box) 

is indicated by the red arrow in Figure 23. 
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Figure 23: Interface used to draw a scale bar on a stack. The “Label all slices” option should be selected so that 

the scale bar is drawn on each frame of the final video. Here, the scale bar was placed “At Selection”, where the 

selection was defined by the rectangular ROI drawn on the image (indicated by red arrow). 

 

Step 8: Label the stack 

In addition to having a scale bar, stacks should be labeled to indicate the passage of time (if 

they were generated using time-lapse images). To create labels, first double click on the 

Text tool (Figure 24, red arrow) to bring up the Fonts interface (Figure 24). Additionally, use 

the Color Picker to choose a text color (I chose white below). 

 

Figure 24: Stack with Fonts and Color Picker interfaces open; red arrow indicates button used to open Fonts 

interface. 

Use a ROI to define the 

placement of the scale bar 
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Once the Text tool has been selected, use the cursor to draw a text box on the stack. The 

text box can be resized or selected and moved with the cursor. Type the appropriate label 

text in the text box (Figure 25). Here, I used “(hr:min)”. The font, font size, and font style 

can be modified using the Fonts interface (Figure 25). 

 

Figure 25: Creation of a text box to label a stack. 

To make the text permanent on the stack, select Edit→Draw (Figure 26). 

 

Figure 26: Draw the text box on the image to make the text permanent. 

After drawing a time label on the stack, add a time stamp that will change as the stack 

progresses from frame to frame. Select Image→Stacks→Label… to add the time stamp 

(Figure 27). 
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Figure 27: Commands to add a time stamp (or other label) to a stack. 

Executing the Label command brings up the Label Stacks interface (Figure 28). Choose the 

format for the label (which will depend on the temporal resolution during image acquisition), 

and define the starting value for the label and the label interval. Here, my interval was “10” 

because images were taken 10 minutes apart. The font size for the label can also be 

adjusted. The font and font style of the label are most easily changed by choosing the “Use 

text tool font” box in the Label Stacks interface. Then, changes to the font in the Fonts 

interface are propagated to the label (see Figure 28). 

 

Figure 28: Label Stacks interface, which is used to add a time stamp or other label to a stack and edit the 

properties of the label. Here, a preview of the time stamp (“00:00”) is shown on the image because the “Preview” 

box in the Label Stacks interface is selected. 
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To set the location of the label, select the “Preview” box in the Label Stacks interface 

(Figure 28). Once this box is selected, a preview of the label will show up on the stack 

(Figure 28). By iteratively changing the “X location” and “Y location” of the label in the Label 

Stacks interface, the label position can be adjusted to reach the appropriate location. Once 

the label appearance and location are satisfactory, click “OK” on the Label Stacks interface 

to add the label to the stack. 

After the video is labeled, it sufficiently annotated and can be saved for journal submission. 

In Figure 29, I’ve shown a still image from the completed video. I have taken the still at 

frame 10 to illustrate how the time stamp progresses as the later images in the stack are 

shown. 

 

Figure 29: Labeled stack; I have progressed the stack to frame 10 to show how the time stamp progresses as 

later images in the stack are shown. 

 

Step 9: Save as video file 

Completed stacks can be saved in file formats compatible with video playback for journal 

submission. To save as an .avi file, select File→Save As→AVI (Figure 30). 
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Figure 30: Commands to save a stack as an .avi file. 

After choosing to save as an .avi file, choose a compression and frame rate in the Save as 

AVI… interface (Figure 31). The frame rate can be adjusted to get the desired playback 

speed. If the movie does not play after saving, the compression strategy may need to be 

changed; it’s possible the player being used doesn’t support the video codec used in 

compression. 

 

Figure 31: Save as AVI… interface in which the compression strategy and frame rate are set. 
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If the movie still does not play in your chosen media player, the File→Save As→Movie… 

option will sometimes allow you to save in another format that may work. 

Final notes 

This process can be modified as needed to meet your needs. For example, you can add 

arrows to point out features of interest in the video by using the same drawing tools 

described above. Furthermore, the text tool can be used to add additional labels and 

annotations to the video (Figure 32). Two versions of the video are available for download 

at my website, colindpaul.weebly.com. 

 

Figure 32: Still image of the video file, with additional annotation added using the text and drawing tools. 

Overall, ImageJ is a powerful and versatile tool for creating video files from experimental 

microscopy data. 

 

http://www.colindpaul.weebly.com/

